Skip to main content
Version: v11.7.1

WaveMaker 10.12.0 - Release date: 2 February 2022

WaveMaker released another version update with new features and bug fixes.


Ending Support of WaveMaker 9 Projects

The existing WM 9 projects move to Archived apps. If you have already initiated upgrading to WM 10, those apps archive as individual versions, such as WM 9 and WM 10. Allowed actions include:

  1. Download Project as Zip
  2. Delete project

For more information, see Archiving WaveMaker 9 Projects.

Bug Fixes

  • Fixed an issue related to Data Table's export to Excel functionality when the table is bound to query variable.
  • Fixed an issue related to the horizontal scroll of the Data Table even when there are enough columns to fit into the table.
  • Fixed an issue related to Dynamic Table. The selected search and column values reset automatically once the search is completed.
  • Fixed an issue related to global search not working in Dynamic Data Table.
  • Fixed an issue related to Data Table column width that is not aligned correctly when the table is present in the Tab Panes.

Technology Stack


UI Frameworks

DescriptionJS LibraryVersion
JS Bindingjquery3.4.1
jquery-ui*1.12.1
MVC Frameworkangular11.2.14
angular-ui-bootstrap3.3.6
ngx-bootstrap6.2
Stylesbootstrap3.3.7
Chartingd33.5.17
nvd31.8.6
Built-in functionslodash4.17.19
Device support, gestureshammerjs2.0.8

Optimised jQuery-UI library excluding unwanted components like accordion, datepicker, dialog, progressbar, spinner, tabs, and all jQuery-UI Effects.

Backend Frameworks

DescriptionJava LibraryVersion
Spring Framework 5.3.13 - 5.3.15
Security frameworkSpring Security5.5.2
Java JSON utilitiesGson 2.8.8 -> 2.8.9
DB Persistence libraryHibernate5.5.7.Final
Sample databaseHSQL2.5.1
JSON libraryJackson2.12.5
Logging frameworkSLF4j1.7.32
Logging ImplementationLog4j22.17.1
Http client libraryHttpComponentshttpclient- 4.5.13 httpmime- 4.5.6
Servlet Framework3.1.0
Database Connection PoolingHikariCP4.0.3

Runtime Environment

DescriptionVersion
JDK1.8
WebSphere8.5.5
JBoss7.1.1
Tomcat8.5*
Cordova (mobile apps) Android iOS10.0.0 10.1.0 6.1.0

This is the default Tomcat runtime support. Apps can be deployed to any standard Java Web Server running on JDK 1.8. For more information, see here.