Skip to main content
Version: v11.7.1

WaveMaker 10.6.2 - Release date: 18 January 2021

WaveMaker released a new update version with some bug fixes.

Improvements


  • Supports base64 encoded pdf as a source for the Iframe widget.
  • Introduced an option to close or clear the search/autocomplete results for the Search widget.

Bug Fixes

  • Fixed an issue related to validation errors when using jQuery for page load.
  • Fixed an issue related to the offline database; it was not working when using a pull configuration query.
  • Fixed an issue related to the OpenID authentication when it should redirect to the same URL after logging in.
  • Fixed an issue related to Min date/Max date validation in date type widgets for mobile.
  • Fixed an issue related to the Number widget for a particular value, including 1.39 and 1.59. When entered in the number widget as a default value, it appends 9's and 0's.
  • Fixed an issue related to the date picker placeholder in mobile apps, which was not showing correctly.
  • Fixed an issue related to the TextArea widget that did not support Width and height set in %.

Technology Stack


UI Frameworks

DescriptionJS LibraryVersion
JS Bindingjquery3.3.1
jquery-ui*1.12.1
MVC Frameworkangular9.1.12
angular-ui-bootstrap3.3.6
ngx-bootstrap5.4
Stylesbootstrap3.3.7
Chartingd33.5.17
nvd31.8.6
Built-in functionslodash4.17.11
Device support, gestureshammerjs2.0.8

Optimised jQuery-UI library excluding unwanted components like accordion, datepicker, dialog, progressbar, spinner, tabs, and all jQuery-UI Effects.

Back-end Frameworks

DescriptionJava LibraryVersion
Spring Framework5.2.9
Security frameworkSpring Security5.4.1
Java JSON utilitiesGson2.8.6
DB Persistence libraryHibernate5.4.22 final
Sample databaseHSQL2.5.1
JSON libraryJackson2.11.3
Logging frameworkSLF4j1.7.30
Log4jlog4j2Version - 2.13.3
Http client libraryHttpComponentshttpclient- 4.5.13 httpmime- 4.5.6
REST API annotationsSwagger1.3.10
Date Time FrameworkJava 8 Date/Time API
Json Librariescom.tdunning1.8
Servlet Framework3.1

Run Time Environment

DescriptionVersion
JDK1.8
WebSphere8.5.5
JBoss7.1.1
Tomcat8.5*
Cordova (mobile apps) Android iOS10.0.0 9.0.0 6.1.0

This is the default Tomcat runtime support. Apps can be deployed to any standard Java Web Server running on JDK 1.8. For more information, see here.